CrowdStricke and Microsoft Outage
Incident Report for Teltek Systems Inc
Resolved
The issue has been identified, isolated, and a fix has been deployed by CrowdStrike.

Key Points:

- Our services: Completely unaffected and operating smoothly.
- Potential external issues: Some users might have experienced difficulties due to their local carrier's involvement with the CrowdStrike outage.

This message is intended to keep you informed about the wider situation. Rest assured, our team is continuously monitoring our systems to ensure they remain stable and reliable
Posted Jul 19, 2024 - 15:16 EDT
Identified
Microsoft Cloud services have been impacted by a glitch stemming from the latest update provided by the security company CrowdStrike. This incident has affected various components, including Virtual Machines, Servers, and any data or services managed within Microsoft Cloud Services, including access to Microsoft 365 applications.

The issue has been isolated and are actively working to restore services. We anticipate that services will be gradually reinstated over the coming hours.
Posted Jul 19, 2024 - 09:05 EDT
This incident affected: Microsoft Network (Microsoft 365, Microsoft Cloud Services).